Pixelated a phpBB Template by SkaidonDesigns
 
ode.petrucci.ch Forum Index ode.petrucci.ch
The unofficial ODEF - Open Dynamics Engine Forum
  Register
ODE 0.5 home page
ODE documentation as HTML
ODE documentation as PDF
WIKI page
All patches posted by users
DOWNLOAD ODE 0.5
ODE PROJECTS AND TUTORIALS
FAQ
Search
Memberlist
Usergroups
Profile
Log in to check your private messages
Log in

trimesh terrain and heavy car

 
Post new topic   Reply to topic    ode.petrucci.ch Forum Index -> Questions/Requests
View previous topic :: View next topic  
Author Message
arth
ODE Newbie


Joined: 16 Apr 2005
Posts: 2

PostPosted: Sat Apr 16, 2005 9:29 pm    Post subject: trimesh terrain and heavy car Reply with quote
hi!
me and my classmate are using ode for a project and we've been having alot of problems but we're soon done. we have one major problem now.
we have a car that starts of by landing on a trimesh ground (generated from a heightmap) and the car has 4 wheels that are cylinders. when the car lands on the ground, everything is fine. but when we start driving forward, the car falls through the ground (the chassi of the car is not collision detected). however, since we want somewhat lifelike values on the car, the weight of the chassi is 1600 (kg). if we lower that value to 100, the car works fine.. atleast for a while. after driving around, the car falls through the ground and the car bounces around alot.
the question now is, what differance does it make that the cars weight is 1600 compared to 100? and is our approch prefered as having the actual values of the car or should we somehow scale them down?
Back to top
View user's profile Send private message

Author Message
render
ODE Newbie


Joined: 13 Apr 2005
Posts: 15

PostPosted: Sun Apr 17, 2005 2:53 am    Post subject: Reply with quote
Hmm, sounds like a problem with your CFM and/or ERP values. Have you tried playing around with them? You say the car is bouncing around a lot with a lower weight value, too. Are you using dContactBounce as a surface mode flag in your collision code?...
Back to top
View user's profile Send private message

Author Message
arth
ODE Newbie


Joined: 16 Apr 2005
Posts: 2

PostPosted: Mon Apr 18, 2005 7:22 pm    Post subject: Reply with quote
just realized that we are not using cylinders for our tires but spheres..
anyway, we have been playing around with the cfm and erp values but with no luck. currently cfm is set to 0 and erp is set to 0.4.
also, what i mean by the car is bouncing around is that it's like it drives on a dirt road or something. it feels like it's very sensitive to the triangle edges. but we haven't tried any other combinations "contact[i].surface.mode" values. it's currenty set to dContactBounce. thanks for the tip
Back to top
View user's profile Send private message

Display posts from previous:   
Post new topic   Reply to topic    ode.petrucci.ch Forum Index -> Questions/Requests All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group


 
phpBB Template designed by SkaidonDesigns